CREATING ACCESSIBLE CONTENT WITH DREAMWEAVER CS5

DREAMWEAVER FEATURES

ACCESSIBILITY PROMPTS

Dreamweaver has accessibility features that, when enabled, prompt the user to add accessibility attributes.

To enable the accessibility features of Dreamweaver:

Select Edit > Preferences > Accessibility and then check the boxes for Form objects, Frames, Media, and Images.

ACCESSIBILITY REPORTING

Dreamweaver can validate against common accessibility standards and give feedback regarding the accessibility of web content.

The reports can be accessed by selecting Site > Reports.

ACCESSIBILITY REFERENCE

Among the other reference materials included in Dreamweaver, there is an Accessibility Reference, provided by UsableNet. Choose Window > Reference to open the reference panel at the bottom of the screen and select UsableNet Accessibility Reference under Book.

ACCESSIBLE AUTHORING INTERFACE

Most of the dialogs, menus, and other interface elements are accessible to screen readers.

ACCESSIBLE IMAGES
• Use graphics to illustrate procedures, processes and concepts.
• Make choose color combinations with enough contrast to be understandable when viewed without color.
• Provide alternate text for all images.
• Make sure the alternate text communicates the purpose of the graphic.
• Provide empty or “null” alt text for graphics that do not convey content such as spacer gifs or decorator images.
• Provide alt text for both the main image and the hotspots of an image map.
• Limit the use of text within graphics
• Ensure that animated graphics do not flicker between 2 and 55 times per second.
• Add alternate text for images, and image maps.

**Images**

Choose Insert > Image

Dreamweaver prompts the user for alternative text when an image is inserted into the document.

- Limit alternate text to around 50 characters.
- For longer descriptions, consider providing a link, in the Long Description text box, to a file that gives more information about the image.
- Example of code for an image tag with a long description:
  ```html
  <img src="emptyalt.gif" alt="properties panel with empty chosen" width="600" height="106" longdesc="longdescription.txt" />
  ```

If an image already inserted into your document needs alternate text:

Select the image and type the alternate text in the alt box in the Properties panel.

**Image Maps:**

Select the image map and add hotspots using the tools on the Property Inspector.
With a hotspot selected you can add alternate text in the Property Inspector:

**ADDING EMPTY ALT TAGS FOR DECORATIVE IMAGES, SPACER GIFS, ETC.**

Sometimes it is appropriate to create empty alt tags (alt="") when the image is purely decorative or otherwise not essential to someone listening to the page with a screen reader. A screen reader will skip over an image marked with alt="".

To create an empty alt tag for an image in Dreamweaver:

- Select the image, click on the arrow at the right edge of the Alt text box and choose <empty>

**ACCESSIBLE FORMS**

**FORM LABELS**

Dreamweaver will prompt for appropriate labels when form elements are added to your web page.

Type the appropriate form label into the Label dialog box.

Select the label style and position.

The best results are accomplished by selecting Attach label tag using 'for' attribute. This allows the form label to be moved to another position within the page and is most compatible with existing screen readers.

You still need to select the form object and change its default name in the Properties panel.

If you chose "Attach label using 'for'" you have one more step:
Select the label text.

On the gray bar at the bottom of the window right click on the `<label>` tag and choose "Quick Tag Editor."

Change the default form object name to match - the name you gave it in the Properties panel.

```
Edit tag: <label for="textfield" />
```

```
Edit tag: <label for="LastName" />
```

**FRAME TITLES**

Dreamweaver will prompt you for frame titles when a new frameset document is created if the accessibility option for frames has been set within the preferences.

The Title option should be a brief description of the frame contents or functionality. This information will be read by a screen reader to identify the frame. The Frame Tag Accessibility Attributes dialog will only be displayed if you create a new frameset document (File > New > Framesets) and will not display if you modify an existing document into a framed page (Modify > Frameset > Split Frame).

**CREATING ACCESSIBLE TABLES**

**LAYOUT TABLES:**

Ensure that the contents of the table make sense when linearized (i.e. when removed from the table).

Do not use table headers (<th> tags) for visual effect.

Use proportional sizing, rather than absolute sizing.

Use the simplest table configuration possible.

**DATA TABLES**

Designate row and column headers using the `<th>` tag.

Associate the data cells with the appropriate headers.
Use proportional sizing, rather than absolute sizing.

Provide names or titles for data tables using the `<caption>` tag.

Provide summaries using the `summary` attribute.

Avoid spanned rows or columns.

Avoid tables with more than two levels of row and/or column headers.

**Designate Row and Column Headers Using the `<th>` Tag**

The first step toward creating an accessible data table is to designate row and/or column headers. In Dreamweaver, click in the cell that you want to designate as a header and then check the header box in the Property Inspector window:

![Property Inspector window](image)

In the markup, the `<td>` tag is used for table data cells and the `<th>` tag is used for table header cells. In the following data table example, the column headers for this table are "Name," "Age," and "Birthday." The row headers are "Jackie" and "Beth."

### Shelley's Daughters

<table>
<thead>
<tr>
<th>Name</th>
<th>Age</th>
<th>Birthday</th>
</tr>
</thead>
<tbody>
<tr>
<td>Jackie</td>
<td>5</td>
<td>April 5</td>
</tr>
<tr>
<td>Beth</td>
<td>8</td>
<td>Jan. 14</td>
</tr>
</tbody>
</table>

**Associate the Data Cells with the Appropriate Headers**

Now that we've created headers, we need to associate the cells with the appropriate headers. Unfortunately, there aren't many tools that will do this for you. You have to go into the markup and do it yourself. There are two ways to do associate data cells with their headers.

1. **Scope**

   The scope attribute should be used on simple data tables such as the one in this example. Here is the markup for the table, using the scope attribute:

   ```html
   <table border="1" align="center">
   <caption>Shelly's Daughters</caption>
   <tr>
     <th scope="col">Name</th>
     <th scope="col">Age</th>
     <th scope="col">Birthday</th>
   </tr>
   <tr>
     <td scope="row">Jackie</td>
     <td>5</td>
     <td>April 5</td>
   </tr>
   <tr>
     <td scope="row">Beth</td>
     <td>8</td>
     <td>Jan. 14</td>
   </tr>
   ```
The scope tag tells the browser and screen reader that everything under the column is related to the header at the top, and everything to the right of the row header is related to that header.

<table>
<thead>
<tr>
<th>Name</th>
<th>Age</th>
<th>Birthday</th>
</tr>
</thead>
<tbody>
<tr>
<td>Jackie</td>
<td>5</td>
<td>Apr 5</td>
</tr>
<tr>
<td>Beth</td>
<td>8</td>
<td>Jan 14</td>
</tr>
</tbody>
</table>

2. HEADERS AND "ID"

Another way to accomplish the same purpose is to use the "headers" and "id" attributes. The markup looks like this:

```html
<table border="1" align="center">
  <caption>Shelly's Daughters</caption>
  <tr>
    <th id="name">Name</th>
    <th id="age">Age</th>
    <th id="birthday">Birthday</th>
  </tr>
  <tr>
    <th id="jackie">Jackie</th>
    <td headers="age jackie">5</td>
    <td headers="birthday jackie">April 5</td>
  </tr>
  <tr>
    <th id="beth">Beth</th>
    <td headers="age beth">8</td>
    <td headers="birthday beth">January 14</td>
  </tr>
</table>
```
This method is more complex. It should be used with tables of a more complex nature, where the scope attribute will not work.

**PROVIDE NAMES OR TITLES FOR DATA TABLES USING THE <CAPTION> TAG**

Tables ought to have some sort of title or caption to them. This is properly done by using the caption tag, right after the opening <table> tag, like this:

```html
<table border="1" align="center">
  <caption>Shelly's Daughters</caption>
</table>
```

**PROVIDE SUMMARIES USING THE SUMMARY ATTRIBUTE**

This guideline is not a requirement for simple tables, but can greatly increase the comprehension of more complex tables. A complex table of weather data might have a summary that says:

"A warming trend has been observed in Cache Valley, with temperatures about 5 degrees above historical averages over the last two months, with the highest temperature difference being 25 degrees above average."

Such a description would highlight the important elements of a table, and help the user to know what to look for in the data.

**HTML EXAMPLE:**

```html
<table border="1" align="center" summary="A warming trend has been observed in Cache Valley, with temperatures about 5 degrees above historical averages over the last two months, with the highest temperature difference being 25 degrees above average."/>
```

**PAGE STRUCTURE AND LAYOUT**

The main content should be visible near the top of the page, without any scrolling. Give as much space to the main content as possible and reduce the size of navigational features as much as possible while still keeping them legible. Test your layout on people who have never seen the layout before.

**PROVIDE A WAY TO QUICKLY GET TO THE MAIN CONTENT**

People using the keyboard or keyboard-emulation devices appreciate being able to skip past the navigational menu system, so that they can jump directly to the main content of the page. Imagine listening to, or tabbing through, a list of 13 items on every page before arriving at the pages’ main content. It can be quite tiring.

**ADD A VISIBLE OR INVISIBLE LINK TO THE MAIN CONTENT**

Insert an anchor at the beginning of the main content. (Insert > Named anchor)

Put the link to main content at the beginning of the page.

To make the link invisible, make a style for hidden text and apply that style to the link to main content

**NOTE:** the hidden links to main content are easily read by screen readers. The links will be also visible when the styles are turned off

**MARKING UP QUOTATIONS.**

There is an easy way to markup a section of text as a quotation using the <blockquote> tag. Unfortunately, Dreamweaver uses an icon that gives the false impression that the <blockquote> element is meant to be used for indentation purposes. In reality, this tag should only be used to set aside quotations.
WEB ACCESSIBILITY STANDARDS AND GUIDELINES

Illinois Information Technology Accessibility Act (IITAA)
http://www.dhs.state.il.us/page.aspx?item=32765

W3C Web Content Accessibility Guidelines
http://www.w3.org/TR/WAI-WEBCONTENT/full-checklist.html

Section 508 Checklist
http://www.webaim.org/standards/508/checklist

TUTORIALS AND TOOLS.

Cynthia Says - http://www.cynthiasays.com/
Section 508 standards and/or the WCAG guidelines. This free tool is intended for educational purposes and only validates one page at a time.

This tool checks single HTML pages for conformance with accessibility standards to ensure the content can be accessed by everyone.

WAVE – http://wave.webaim.org/
A free web accessibility evaluation tool provided by WebAIM. WAVE shows the original web page with embedded icons and indicators that reveal the accessibility of that page.

This section of the WebAIM site features articles to help you understand the concepts as well as the techniques needed to design accessible web sites.

Complete List of Web Accessibility Evaluation Tools - http://www.w3.org/WAI/ER/tools/complete
From the W3C Web Accessibility Initiative

HTML AND CSS VALIDATION

W3C Validation Service
http://validator.w3.org

W3C CSS Validation Service
http://jigsaw.w3.org/css-validator

CPG 5/4/2011