OBJECTIVES:

1. Understand the Excel interface
2. Learn to create a basic worksheet
3. Add and edit cell content
4. Change worksheet structure: insert and delete rows and columns
5. Learn to work with formulas and functions
6. Format and print worksheets
7. Format data
UNDERSTANDING THE EXCEL INTERFACE

THE RIBBON

Notice that the ribbon is divided into different sections, grouping related commands together.

EXCEL WORKSHEET

TERMINOLOGY

spreadsheet  
a grid composed of rows and columns
worksheet  
what spreadsheets are called in Excel
workbook  
an Excel file, which can contain multiple worksheets.
worksheet tabs  
located at the bottom of the workbook window, for quickly switching between worksheets

MOVING THE CURSOR AROUND

You have to make a cell active to type in it. Click on a cell to make it active or move the cell cursor (the thick black outline) using the arrow key or the TAB key. Table 1 shows the most common shortcuts for moving the cell cursor.

<table>
<thead>
<tr>
<th>Press This..</th>
<th>To Move...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Arrow Keys</td>
<td>One cell in the direction of the arrow</td>
</tr>
<tr>
<td>Tab</td>
<td>One cell to the right</td>
</tr>
<tr>
<td>Shift + Tab</td>
<td>One cell to the left</td>
</tr>
<tr>
<td>Control + End</td>
<td>To the last cell in the worksheet</td>
</tr>
<tr>
<td>Home</td>
<td>To the beginning of the row containing the active cell</td>
</tr>
</tbody>
</table>
SELECT RANGES OF CELLS

SELECT A COLUMN
1. Move the cursor over the letter of the column heading until the cursor becomes a black arrow pointing down.
2. Click the column heading to select the entire column.

SELECT A ROW
1. Move the cursor over the number of the row to be selected until the cursor becomes a black arrow pointing to the right.
2. Click the row number to select the entire row.

Note that the row and column headers turn green when selected.

SELECT A BLOCK OF CELLS USING THE KEYBOARD:
1. Click a cell to select it.
2. Hold down the SHIFT key and use the RIGHT-ARROW key to move to the right and then the DOWN ARROW key to move down to select the desired block of cells.
3. To add additional individual cells to the selection, hold down the CTRL key and click the desired cells using the mouse.

SELECT A BLOCK OF CELLS USING THE MOUSE:
1. Click and drag to select a block of cells.
2. To add additional individual cells to the selection, hold down the CTRL key and click the desired cells using the mouse.

TYPING AND EDITING CELL CONTENT

ADDING CONTENT
To type in a cell, select the cell and start typing.

Notice that the text that you typed in the cell also appears in the formula bar.

EDITING CONTENT
1. Click in the cell and start typing to overwrite the content.
2. Delete content by right-clicking on the cell and choosing Clear Contents from the menu that appears.

OR: Click the cell and use the DELETE key.
COPY AND MOVE DATA BETWEEN CELLS

Mouse Method:

1. Select the cell or block of cells.
2. Point at the border of the selection so that the mouse pointer becomes a 4 pointed arrow.
3. Drag the selection to a new location
4. If you want to copy rather than move, hold down the CTRL key while you drag.

Clipboard Method

1. Select the cell or block of cells.
2. Click the Home tab and choose Cut (or copy)
3. Either select the same size and range of cells for the destination OR select one cell, which will become the top left corner of the destination
4. Choose the Home tab and Paste

USE AUTOFILL TO FILL CELL CONTENT

Autofill can save time when you have content to enter that follows a repeatable pattern or sequence. Depending on how it’s used it can either fill the same value into a target area or fill in a sequence such as:

- Days of the week
- Months of the year
- A numeric sequence (2,4,6,8)

AUTOFILL RULES:

- When Autofill recognizes selected text as belonging to a preset list (days of the week, months of the year), it fills in automatically from the list. For example, if the selected cell contains August, it will add September to the adjacent cell to the right.
- When Autofill does not recognize the text, it fills with a duplicate of the selected text.
- If one cell containing a number is selected, Autofill adds a duplicate of the number.
- If more than one cell containing numbers are selected, it tries to determine a pattern and continue filling with that pattern.

Fill Handle – the fill handle is the little black square in the lower right-hand corner of the selected cell or range.

TO USE AUTOFILL:

1. Select the cell or cells.
2. Move the cursor over the fill handle. The cursor becomes a black crosshair. (+)
3. Click and drag the fill handle across a row or down a column.
4. Note that an icon appears at lower left. Click on the black triangle to see and choose Autofill options.
CHANGING WORKSHEET STRUCTURE
INSERT AND DELETE ROWS AND COLUMNS

Using DELETE or BACKSPACE buttons on your keyboard only clears the content of selected cells rows or columns. To delete cells, rows or columns from the worksheet, select the Home tab and use the Delete command on the ribbon:

- For additional options click the black triangle next to Insert and Delete on the Ribbon.
- When you insert a row or column, the existing ones move to make room for it.
- To insert multiple row or columns, select multiple rows or columns before using the Insert command.

WORKING WITH WORKSHEETS
Each new workbook (Excel file) comes with one worksheet named Sheet1. Click the plus (+) on the bottom bar to add more sheets.

You can rename, move, copy or hide a worksheet, or change the worksheet tab color. Right click on a worksheet tab on the bottom bar to get the menu for these options:
CREATE FORMULAS AND FUNCTIONS

WRITING FORMULAS THAT CALCULATE

You can write formulas that Excel will execute as a calculator

<table>
<thead>
<tr>
<th>Order Executed</th>
<th>Item</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Anything in parentheses</td>
<td>=4* (3 + 2)</td>
</tr>
<tr>
<td>2</td>
<td>Exponents</td>
<td>=5^3</td>
</tr>
<tr>
<td>3</td>
<td>Multiplication and division</td>
<td>=5+ 3*4</td>
</tr>
<tr>
<td>4</td>
<td>Addition and subtraction</td>
<td>=10-4</td>
</tr>
</tbody>
</table>

Example of a formula written directly into the formula box:

Writing formulas that reference other cells

This is Excel’s biggest strength. By using formulas that reference cells, the formula results will change if you change the value in one of the cells.

SUM function - Adds (or sums) a data range consisting of one or more cells:

=SUM(B2:B10) colon between the first and last cell in a row or column.

OR adds individual cells such as:  =SUM(B2, C6, D9) commas between each individual cell referenced.

REFERENCE A CELL ON ANOTHER SHEET

When referring to a cell on another sheet, list the sheet name, followed by an exclamation point, followed by the cell reference:

=Sheet1!B10

ABSOLUTE REFERENCING

An absolute cell reference does not change when copied to another cell. Add a dollar sign before the column letter and before the cell number to make a reference absolute.

- For example: $B$15
- Formulas can contain both relative and absolute references: =F13*$B$15
THE AUTOSUM BUTTON

- Instead of typing in the SUM formula, you can use the AutoSum button.
- The AutoSum button is on the ribbon under both the Home tab and the Formulas tab.
- Note that you can use the AutoSum button to choose other functions such as calculating averages and counting numbers.

USING THE AUTOSUM BUTTON

1. Click the cell that will display the sum results
2. Choose the Formulas tab -> AutoSum.
   OR use the AutoSum button on the Home tab
3. A dotted line will appear around a range of adjacent cells. If these are not the cells you want, click and drag the fill handle to select a range of cells, OR hold down the CTRL key and click individual cells to add to the formula.
4. Press Enter.
FORMATTING WORKSHEETS

WRAP TEXT IN A CELL

Use the Wrap Text button on the Home tab to expand the cell height to display all the content on multiple lines.

MERGE CELLS AND CENTER TEXT

- Select the cell you want to merge.
- Use the Merge & Center button on the Home tab.

The Merge & Center button joins the selected cells together and centers the contents in the new cell.

FORMAT NUMBERS

1. On the Home tab find the Number section for quickly changing the number format.
2. Click the black triangle to see more options including date, time and fraction formats.
ADD HEADERS AND FOOTERS

Choose **Insert** tab -> Header & Footer (in the Text section of the Ribbon)

The Header & Footer Tools design tab opens, with options to add page numbers, date, time, etc. and an area to type the header text

FORMAT A RANGE AS A TABLE

Formatting a range as a table allows you to quickly apply preset formatting. It also gives the range special properties that make it easier to search and sort them.

1. Select a range of cells
2. Choose the **Home** tab -> **Format as Table**.
3. Choose a style from the gallery of styles displayed.
4. The Format as Table dialog box opens with the range already filled in from the selection you made in step 1.
5. Click OK. The range is converted to a table and the style is applied.
USING THEME FORMATTING

Themes are preset formats that can be added to entire worksheets. The themes are standard across Word, PowerPoint and Excel, so you can use the same formatting for all your documents.

TO APPLY A WORKBOOK THEME:

1. Choose the Page Layout tab -> Themes button.
2. A gallery of themes will appear.
3. Pick a theme to apply to your worksheet.

Customize the theme that you have chosen by changing the colors, fonts and effects:

CELL FORMATTING

Excel has a gallery of preformatted styles that can be applied to cells. You can also create custom styles to reuse and apply quickly.
1. Select the cell or cells you want to format.
2. **Home** tab -> choose the Cell Styles button.
3. Click on a style to apply to the selected cells.

**Hiding Columns and Rows**

You can hide entire columns and rows. Use this to conceal sensitive information or to remove unnecessary information or blank rows or columns for printing.

**To Hide a Column or Row**

- Right-click on a row or column that you want to hide and choose Hide from the menu that appears.
- OR select the columns or rows to be hidden and choose **Home** tab -> Format -> Hide & Unhide -> Hide Columns+

**To Reveal Hidden Columns or Rows**

**Columns:**

- Select the columns on either side (left and right) of the hidden column or columns, right-click and choose Unhide.
- OR Select the columns on either side (left and right) of the hidden column or columns, choose **Home** tab -> Format-> Hide & Unhide-> Unhide Columns

**Rows:**

- Select the rows above and below the hidden row or rows, right-click and choose Unhide.
- OR Select the rows above and below the hidden row or rows, then choose **Home** tab -> Format-> Hide & Unhide-> Unhide Rows
FREEZE PANES
On the View tab, the Freeze Panes button provides several options for keeping selected rows and/or columns visible as you scroll through the worksheet.

WORKING WITH TABLES
In addition to allowing you to use preset formatting, converting a range to a table enables you to perform functions such as sorting and filtering data.

CONVERT A DATA RANGE TO A TABLE
1. Select a range of cells.
2. Choose the Insert tab and then click the Table button on the ribbon.
3. The Create Table dialog box open with the selected range already filled in.
4. Click OK.
5. The range is converted to a table with default table formatting and filter arrows for each column.

SORT TABLE DATA
Data in tables can be sorted by single or multiple fields. Use the arrow next to each column to sort based on that column.

PRINTING WORKSHEETS
By default Excel prints the entire active worksheet. However, other options include printing the entire workbook, printing selected worksheets, or printing selected cells.

PRINT MULTIPLE WORKSHEETS
To print multiple worksheets from the Excel workbook, hold down the SHIFT key and select the tabs of the worksheets that you want to print.
PRINT SELECTED CELLS OR RANGES.

To select a range of cells for a one-time print job, simply select the cells and select Print Selection.

SET A PRINT RANGE

If you want the same area of selected cells to print out each time that you print this worksheet in the future:

1. Select the range of cells.
2. Click the Page Layout tab
3. Choose Print Area and Set Print Area
4. When you print the worksheet, only the set print range will be printed.
5. To override, use Ignore Print Area on the print dialog screen.

Carol Gordon cgordon2@siumed.edu

1/6/2016